DNS Connectivity Issues
Incident Report for Sifter
Resolved
DNS issues should be returning to normal.
Posted over 4 years ago. Sep 20, 2014 - 08:35 CDT
Identified
Our DNS provider is currently experiencing a DDoS and working on it. We'll post updates here and on Twitter since DNS resolution may affect the accessibility of our status site here.
Posted over 4 years ago. Sep 20, 2014 - 07:11 CDT