Updating Search
Incident Report for Sifter
Resolved
Search is back up and running. I'm really sorry for the inconvenience, but the updates should definitely be worth it.
Posted almost 5 years ago. Apr 22, 2014 - 06:57 CDT
Identified
We're making some quick upgrades to search that will have it offline for 15-30 minutes. It should be back shortly.
Posted almost 5 years ago. Apr 22, 2014 - 06:14 CDT